Saturday, December 22, 2012

Lots of new equipment

I am having (sort of) fun with setting up my new imaging equipment:
Well, first of all, not all components are here. I have only the 2 cameras and the Robofocus. The OAG and telecompressor will come next week - unfortunately, the filter wheel will come in 3(!!) weeks.

So, it will take a while until I can take images, but I can do the setup.

1. H694 and Lodestar
These were easy to install. The programs from Starlight Xpress worked out-off-the-box.

2. Robofocus
A little bit trickier. Took me half a day to figure out how to setup (removing the focus knob, gluing the motor on the spacer, installing the spacer, wiring). But finally, it's all done:

It's not optimal, that the focuser sticks out so much. But if I rotate it upwards, it interferes with the guiding scope and makes it hard to look through it. Maybe I switch the star finder and the guiding scope (again) to make space for it. But for now, it's OK.
I also have to use a serial-USB adapter to connect it to the USB hub on the scope. Right now, the adapter chooses a new serial port every time I reconnect it - which means that I constantly have to reconfigure the focusing program. I'll try to assign it in Windows' device manager, maybe that sticks.
But I can use the focuser either through the program from Robofocus or with the two buttons on the focuser controller.

3. TheSkyX
OK, I won't event talk about cost here. It seems to be an awesome program, but it better be for the $$$ that I spent...

First, I connected the Robofocus. There isn't native support, but I could connect it through the generic Ascom driver. The whole serial port assignment is really a pain in the ###. I can control the focuser from TheSkyX. But so far, I haven't found a good way to see the continuous camera image plus the focuser control at the same time (which I'd need for obtaining rough focus before letting TheSkyX take over to achieve exact focus).

Second, the H694 camera. I read somewhere that I can connect it to TheSkyX by copying the SX dll into the CCDSoft camera plugin directory. But that didn't work. Others recommended to connect it through the Ascom driver. That worked out of the box. Selected Ascom, selected "Starlight Xpress Main Camera", connected. And everything was OK. Could take pictures, see them, could even take continuous pictures.

Then, the Lodestar. That turned out to be much harder. I tried the Ascom driver. But the problem was that I only had the "Starlight Xpress Main Camera" entry in the camera chooser. Started, restarted, reconfigured, nothing worked. Asked in some forums. I finally re-installed the Starlight Xpress Ascom driver. I am "almost" sure that I chose the same settings. But afterwards, I had a second entry in the camera chooser list: "Starlight Xpress Lodestar". Choosing that worked.

Next night with clear skies I can now try out autoguiding and automatic focusing (of course, all these nights where I ficured out the whole setup it was clear, but where I'm ready it's raining :-(

4. CCDInspector
I haven't figured out yet how to connect CCDInspector to TheSkyX. There are entries for Maxim DL and CCDSoft - but not for TheSkyX. There is a "Generic" setting - the only parameter you can give it is a directory name. I think this will just monitor this directory for new images and use them in the analysis. So far, I wasn't successful in autosaving all the images in TheSkyX. Well, that's what I'll try this weekend...

... and I finally figured it out: this only works from the focusing tab. Have to select "Take Photo Continuously", "Autosave focus photos" and "Automatically save photos". And then point both TheSkyX and CCDInspector to the same directory. Now I can see the images from TheSkyX in the image viewer of CCDInspector (and it even cleans up afterwards!)

So, next clear night, I can try out
  • Manual (rough) focusing through TheSkyX
  • Two-Star Alignment with the H694 through TheSkyX
  • Autotofocusing with @Focus2
  • Autoguiding with TheSkyX
  • Collimation with CCDInspector
Can't wait!!!