Monday, April 24, 2017

Eclipse Orchestrator

For my solar eclipse imaging I found Eclipse Orchestrator. It creates a "script" of exposures to take during the solar eclipse (different exposure times) and then executes that script during the eclipse.

Takes a while (at least for me) to figure everything out:

First try
I couldn't even get my camera to connect / configured in Eclipse Orchestrator. Then I read through the instructions and found that the D750 is not support - but the D7000 is!!!
When I used that camera, EO identified it and I could use it.

Second Try
With my camera recognized, I could create a script for the 2017 solar eclipse (after entering my location data). But when I came to the screen where you enter which images you want to take only a few were enabled (only two if I remember). You have to buy the Pro Version for all these events - it's $109. Not too cheap, but I decided to bite the bullet.
When I now tried to create the script I got an error message "You have commanded too many exposures during totality. Reduce the number of sets and try again" I tried to remove some events or lower some numbers, but always saw the same error message. After MANY trial and errors, I realized that this was cause by the Chromosphere and Prominence images. If I removed both, I didn't get the error message. If only one was present I saw it.
...
Took me a while to realize that I entered the location wrong (I entered East - instead of West). Which means: there was no eclipse at the location I entered!!! As soon as I corrected this, the script was created correctly with the default parameters.

Third try
Next, I was reading that using a camera through a USB, the camera doesn't immediately react and thus you have to keep 2-3 seconds between exposures. Which of course lowers the number of exposures you can take. Good thing is that EO works with DSUBS cables from Shoestring Astronomy. And I still have one from the time when I used my Nikon camera with my telescope (loooooooong time ago!)
I dug the DSUBS cable out, connected it and configured EO accordingly:
And then

Now, I wanted to try the script, but it seemed to do weird things with the camera. I found the menu items Camera->Push Shutter and Camera->Single Exposure w/ Settings for testing the camera. When I used those, the camera would take two exposures - not one!!! This reminded me: I had to set the camera to MUp, so that with the first signal, the mirror moves up, the second opens the shutter and the third closes the shutter. Now, I could take exposures with the menu items.

Fourth Try
I wanted to try the script but realized that I had to plug in the camera (EO is waiting for an ack from the camera before moving on).
I could use Location/Time->Simulated Second Contact. The script would start just before the second contact (with some messages) and then start to take images with the camera.
Only that the camera quickly fell behind and the images were taken WAY too late. Sometimes the camera would start to catch up, but then fall behind again.
It turns out that my SD cards weren't fast enough. I used a SanDisk Extreme SDXC UHS-1 and now everything works smoothly.
The script will take 275 photos, 14.5MB each. I.e the whole script only creates a few GB worth of images! I ordered 2 ultra fast cards (280MB / sec) with "only" 64GB capacity.
One thing I noticed is that the EO can get unstable if you plug the camera in and out or such and then it wouldn't trigger the camera at all anymore. Note to self: always try to take exposures and if it doesn't work, restart!

Fifth Try
I wanted to compare a cropped frame (D7000) with a full frame (D750) through the TOA-130 scope to see which one frames the sun better. Here are the results (not properly focused!)
D750 (full frame) D7000 (cropped frame)
Full frame is definitively better - but then again, EO does not support the D750 yet.
Next, I tried Live View with the D7000. Couldn't get it to work at all ...